summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/graphicsview/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/graphicsview/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/graphicsview/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/auto/widgets/graphicsview/CMakeLists.txt b/tests/auto/widgets/graphicsview/CMakeLists.txt
new file mode 100644
index 0000000000..be1ae7253a
--- /dev/null
+++ b/tests/auto/widgets/graphicsview/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Generated from graphicsview.pro.
+
+if(QT_FEATURE_private_tests)
+ add_subdirectory(qgraphicsanchorlayout)
+ add_subdirectory(qgraphicsanchorlayout1)
+ add_subdirectory(qgraphicsitem)
+ add_subdirectory(qgraphicsscene)
+ add_subdirectory(qgraphicssceneindex)
+endif()
+add_subdirectory(qgraphicseffectsource)
+add_subdirectory(qgraphicsgridlayout)
+add_subdirectory(qgraphicsitemanimation)
+add_subdirectory(qgraphicslayout)
+add_subdirectory(qgraphicslayoutitem)
+add_subdirectory(qgraphicslinearlayout)
+add_subdirectory(qgraphicsobject)
+add_subdirectory(qgraphicspixmapitem)
+add_subdirectory(qgraphicspolygonitem)
+add_subdirectory(qgraphicstransform)
+if(QT_FEATURE_style_fusion)
+ # special case begin
+ # These tests are never run in coin with qmake since the statement
+ # !qtConfig(style-fusion): always passes causing the subdirs to be removed.
+ # For these tests to be generated the .pro file needs to be patched and
+ # the above line changed to !qtConfig(style-fusion). That being said,
+ # one of the test fails and needs to be corrected by someone with know how in
+ # that area. Until then we will disable them to mimic the behavior seen in
+ # coin.
+ #add_subdirectory(qgraphicsproxywidget)
+ #add_subdirectory(qgraphicswidget)
+ # special case end
+endif()
+if(NOT WINRT)
+ add_subdirectory(qgraphicsview)
+endif()