summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/kernel/qapplication/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/kernel/qapplication/test/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/kernel/qapplication/test/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/tests/auto/widgets/kernel/qapplication/test/CMakeLists.txt b/tests/auto/widgets/kernel/qapplication/test/CMakeLists.txt
new file mode 100644
index 0000000000..bc2ef1000f
--- /dev/null
+++ b/tests/auto/widgets/kernel/qapplication/test/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from test.pro.
+
+#####################################################################
+## test Test:
+#####################################################################
+
+# Collect test data
+list(APPEND test_data "../test/test.pro")
+list(APPEND test_data "../tmp/README")
+list(APPEND test_data "../modal")
+
+add_qt_test(tst_qapplication # special case
+ SOURCES
+ ../tst_qapplication.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+ TESTDATA ${test_data}
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/.." # special case
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(tst_qapplication CONDITION builtin_testdata # special case
+ DEFINES
+ BUILTIN_TESTDATA
+)
+
+#### Keys ignored in scope 3:.:.:test.pro:NOT ANDROID AND NOT WINRT:
+# SUBPROGRAMS = "desktopsettingsaware" "modal"
+
+#### Keys ignored in scope 6:.:.:test.pro:NOT ANDROID AND NOT WINRT:
+# TEST_HELPER_INSTALLS = "../debug/helper"
+
+#### Keys ignored in scope 8:.:.:test.pro:NOT ANDROID AND NOT WINRT:
+# TEST_HELPER_INSTALLS = "../release/helper"
+
+#### Keys ignored in scope 10:.:.:test.pro:NOT ANDROID AND NOT WINRT:
+# TEST_HELPER_INSTALLS = "../helper"