summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/kernel/qwidget/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/kernel/qwidget/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/auto/widgets/kernel/qwidget/CMakeLists.txt b/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
new file mode 100644
index 0000000000..ac09f88ae2
--- /dev/null
+++ b/tests/auto/widgets/kernel/qwidget/CMakeLists.txt
@@ -0,0 +1,16 @@
+add_qt_test("tst_qwidget"
+ SOURCES
+ qwidget.qrc
+ tst_qwidget.cpp
+ LIBRARIES
+ Qt::Widgets
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WidgetsPrivate
+ Qt::TestPrivate
+)
+
+extend_target("tst_qwidget" CONDITION APPLE_OSX
+ SOURCES tst_qwidget_mac_helpers.mm
+ LIBRARIES FWSecurity FWAppKit
+)