summaryrefslogtreecommitdiffstats
path: root/tests/auto/widgets/styles/qstylesheetstyle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/widgets/styles/qstylesheetstyle/CMakeLists.txt')
-rw-r--r--tests/auto/widgets/styles/qstylesheetstyle/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/widgets/styles/qstylesheetstyle/CMakeLists.txt b/tests/auto/widgets/styles/qstylesheetstyle/CMakeLists.txt
new file mode 100644
index 0000000000..ca1a2ee062
--- /dev/null
+++ b/tests/auto/widgets/styles/qstylesheetstyle/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from qstylesheetstyle.pro.
+
+if(NOT QT_FEATURE_private_tests)
+ return()
+endif()
+
+#####################################################################
+## tst_qstylesheetstyle Test:
+#####################################################################
+
+add_qt_test(tst_qstylesheetstyle
+ SOURCES
+ tst_qstylesheetstyle.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::TestPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Widgets
+)
+
+# Resources:
+set(resources_resource_files
+ "images/testimage.png"
+ "images/testimage@2x.png"
+)
+
+add_qt_resource(tst_qstylesheetstyle "resources"
+ PREFIX
+ "/"
+ FILES
+ ${resources_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:qstylesheetstyle.pro:<TRUE>:
+# _REQUIREMENTS = "qtConfig(private_tests)"