summaryrefslogtreecommitdiffstats
path: root/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt')
-rw-r--r--tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt47
1 files changed, 26 insertions, 21 deletions
diff --git a/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt b/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
index 1fefea0128..906ee30384 100644
--- a/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
+++ b/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
@@ -1,30 +1,35 @@
-# Generated from sethtml.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## sethtml Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.16)
+project(sethtml LANGUAGES CXX)
-qt_internal_add_executable(sethtml
- GUI
- SOURCES
- main.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#### Keys ignored in scope 1:.:.:sethtml.pro:<TRUE>:
-# FUZZ_ENGINE = "$$(LIB_FUZZING_ENGINE)"
-# QTPLUGIN = "qminimal"
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-## Scopes:
-#####################################################################
+find_package(Qt6 REQUIRED COMPONENTS Core Gui)
-qt_internal_extend_target(sethtml CONDITION FUZZ_ENGINE_ISEMPTY
- LINK_OPTIONS
- "-fsanitize=fuzzer"
+qt_add_executable(sethtml
+ main.cpp
)
-qt_internal_extend_target(sethtml CONDITION NOT FUZZ_ENGINE_ISEMPTY
- PUBLIC_LIBRARIES
+target_link_libraries(sethtml PUBLIC
+ Qt::Core
+ Qt::Gui
+)
+if(DEFINED ENV{LIB_FUZZING_ENGINE})
+ target_link_libraries(sethtml PRIVATE
$ENV{LIB_FUZZING_ENGINE}
+ )
+else()
+ target_link_libraries(sethtml PRIVATE
+ -fsanitize=fuzzer
+ )
+endif()
+
+qt_import_plugins(sethtml
+ INCLUDE Qt::QMinimalIntegrationPlugin
)