summaryrefslogtreecommitdiffstats
path: root/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt')
-rw-r--r--tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt b/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
new file mode 100644
index 0000000000..982957bedf
--- /dev/null
+++ b/tests/libfuzzer/gui/text/qtextdocument/sethtml/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from sethtml.pro.
+
+#####################################################################
+## sethtml Binary:
+#####################################################################
+
+qt_add_executable(sethtml
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:sethtml.pro:<TRUE>:
+# FUZZ_ENGINE = "$$(LIB_FUZZING_ENGINE)"
+# QTPLUGIN = "qminimal"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(sethtml CONDITION FUZZ_ENGINE_ISEMPTY
+ LINK_OPTIONS
+ "-fsanitize=fuzzer"
+)
+
+qt_extend_target(sethtml CONDITION NOT FUZZ_ENGINE_ISEMPTY
+ PUBLIC_LIBRARIES
+ $ENV{LIB_FUZZING_ENGINE}
+)