summaryrefslogtreecommitdiffstats
path: root/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt')
-rw-r--r--tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt47
1 files changed, 26 insertions, 21 deletions
diff --git a/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt b/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
index 637ce2f51b..468b37a8f9 100644
--- a/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
+++ b/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
@@ -1,30 +1,35 @@
-# Generated from beginlayout.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-#####################################################################
-## beginlayout Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.16)
+project(beginlayout LANGUAGES CXX)
-qt_internal_add_executable(beginlayout
- GUI
- SOURCES
- main.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#### Keys ignored in scope 1:.:.:beginlayout.pro:<TRUE>:
-# FUZZ_ENGINE = "$$(LIB_FUZZING_ENGINE)"
-# QTPLUGIN = "qminimal"
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-## Scopes:
-#####################################################################
+find_package(Qt6 REQUIRED COMPONENTS Core Gui)
-qt_internal_extend_target(beginlayout CONDITION FUZZ_ENGINE_ISEMPTY
- LINK_OPTIONS
- "-fsanitize=fuzzer"
+qt_add_executable(beginlayout
+ main.cpp
)
-qt_internal_extend_target(beginlayout CONDITION NOT FUZZ_ENGINE_ISEMPTY
- PUBLIC_LIBRARIES
+target_link_libraries(beginlayout PUBLIC
+ Qt::Core
+ Qt::Gui
+)
+if(DEFINED ENV{LIB_FUZZING_ENGINE})
+ target_link_libraries(beginlayout PRIVATE
$ENV{LIB_FUZZING_ENGINE}
+ )
+else()
+ target_link_libraries(beginlayout PRIVATE
+ -fsanitize=fuzzer
+ )
+endif()
+
+qt_import_plugins(beginlayout
+ INCLUDE Qt::QMinimalIntegrationPlugin
)