summaryrefslogtreecommitdiffstats
path: root/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt')
-rw-r--r--tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt b/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
new file mode 100644
index 0000000000..1810c5ed6f
--- /dev/null
+++ b/tests/libfuzzer/gui/text/qtextlayout/beginlayout/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from beginlayout.pro.
+
+#####################################################################
+## beginlayout Binary:
+#####################################################################
+
+qt_add_executable(beginlayout
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+#### Keys ignored in scope 1:.:.:beginlayout.pro:<TRUE>:
+# FUZZ_ENGINE = "$$(LIB_FUZZING_ENGINE)"
+# QTPLUGIN = "qminimal"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(beginlayout CONDITION FUZZ_ENGINE_ISEMPTY
+ LINK_OPTIONS
+ "-fsanitize=fuzzer"
+)
+
+qt_extend_target(beginlayout CONDITION NOT FUZZ_ENGINE_ISEMPTY
+ PUBLIC_LIBRARIES
+ $ENV{LIB_FUZZING_ENGINE}
+)