summaryrefslogtreecommitdiffstats
path: root/tests/manual/cmake/fail4/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/cmake/fail4/CMakeLists.txt')
-rw-r--r--tests/manual/cmake/fail4/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/manual/cmake/fail4/CMakeLists.txt b/tests/manual/cmake/fail4/CMakeLists.txt
new file mode 100644
index 0000000000..dcd4b8bd65
--- /dev/null
+++ b/tests/manual/cmake/fail4/CMakeLists.txt
@@ -0,0 +1,18 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(pass4)
+
+find_package(Qt5Core REQUIRED)
+
+include_directories(${Qt5Core_INCLUDE_DIRS})
+
+qt5_wrap_cpp(moc_files myobject.h)
+
+# Test options. The -binary option generates a binary to dlopen instead of
+# a source file to compile. The compiler will consider it garbage when used
+# in the add_executable call.
+qt5_add_resources(rcc_files "pass4.qrc" OPTIONS -binary)
+
+add_executable(myobject myobject.cpp ${moc_files} ${rcc_files})
+target_link_libraries(myobject ${Qt5Core_LIBRARIES})