summaryrefslogtreecommitdiffstats
path: root/tests/manual/cmake/pass8/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/cmake/pass8/CMakeLists.txt')
-rw-r--r--tests/manual/cmake/pass8/CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/tests/manual/cmake/pass8/CMakeLists.txt b/tests/manual/cmake/pass8/CMakeLists.txt
deleted file mode 100644
index 735b1bd26e..0000000000
--- a/tests/manual/cmake/pass8/CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-
-cmake_minimum_required(VERSION 2.8)
-
-project(pass8)
-
-find_package(Qt5Core REQUIRED)
-
-include_directories(${Qt5Core_INCLUDE_DIRS})
-
-add_definitions(${Qt5Core_DEFINITIONS})
-
-qt5_wrap_cpp(moc_files myobject.h)
-
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-
-# On non-windows, the WIN32 is harmless, and Qt5Core_QTMAIN_LIBRARIES is empty.
-# We test that it is harmless on those, and test that it builds on Windows.
-# It wouldn't build if WIN32 is used and Qt5Core_QTMAIN_LIBRARIES is empty.
-add_executable(myobject WIN32 myobject.cpp ${moc_files} )
-target_link_libraries(myobject ${Qt5Core_LIBRARIES} ${Qt5Core_QTMAIN_LIBRARIES})