summaryrefslogtreecommitdiffstats
path: root/tests/manual/embeddedintoforeignwindow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/embeddedintoforeignwindow/CMakeLists.txt')
-rw-r--r--tests/manual/embeddedintoforeignwindow/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/manual/embeddedintoforeignwindow/CMakeLists.txt b/tests/manual/embeddedintoforeignwindow/CMakeLists.txt
index 84ce8b4daa..a80206133b 100644
--- a/tests/manual/embeddedintoforeignwindow/CMakeLists.txt
+++ b/tests/manual/embeddedintoforeignwindow/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from embeddedintoforeignwindow.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## embeddedintoforeignwindow Binary:
@@ -12,26 +13,25 @@ qt_internal_add_manual_test(embeddedintoforeignwindow
../diaglib/textdump.cpp ../diaglib/textdump.h
itemwindow.cpp itemwindow.h
main.cpp
+ NO_PCH_SOURCES
+ itemwindow.cpp # undef QT_NO_FOREACH
DEFINES
QT_DIAG_LIB
INCLUDE_DIRECTORIES
../diaglib
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
)
-#### Keys ignored in scope 1:.:.:embeddedintoforeignwindow.pro:<TRUE>:
-# TEMPLATE = "app"
-
## Scopes:
#####################################################################
qt_internal_extend_target(embeddedintoforeignwindow CONDITION WIN32
SOURCES
../diaglib/nativewindowdump_win.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
user32
)
@@ -45,14 +45,14 @@ qt_internal_extend_target(embeddedintoforeignwindow CONDITION QT_FEATURE_widgets
../diaglib/debugproxystyle.cpp ../diaglib/debugproxystyle.h
../diaglib/logwidget.cpp ../diaglib/logwidget.h
../diaglib/qwidgetdump.cpp ../diaglib/qwidgetdump.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::WidgetsPrivate
)
qt_internal_extend_target(embeddedintoforeignwindow CONDITION QT_FEATURE_opengl
SOURCES
../diaglib/glinfo.cpp ../diaglib/glinfo.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::OpenGL
Qt::OpenGLWidgets
)