summaryrefslogtreecommitdiffstats
path: root/tests/manual/highdpi/pixelgadget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/highdpi/pixelgadget/CMakeLists.txt')
-rw-r--r--tests/manual/highdpi/pixelgadget/CMakeLists.txt28
1 files changed, 11 insertions, 17 deletions
diff --git a/tests/manual/highdpi/pixelgadget/CMakeLists.txt b/tests/manual/highdpi/pixelgadget/CMakeLists.txt
index 888ce95a8e..2cc04225df 100644
--- a/tests/manual/highdpi/pixelgadget/CMakeLists.txt
+++ b/tests/manual/highdpi/pixelgadget/CMakeLists.txt
@@ -1,19 +1,13 @@
-# special case skip regeneration
-cmake_minimum_required(VERSION 3.16)
-project(pixelgadget LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-
-qt_add_executable(pixelgadget
- main.cpp
-)
-
-target_link_libraries(pixelgadget PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Widgets
+#####################################################################
+## pixelgadget Binary:
+#####################################################################
+
+qt_internal_add_manual_test(pixelgadget
+ GUI
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::Widgets
)
-