summaryrefslogtreecommitdiffstats
path: root/tests/manual/lance/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/lance/CMakeLists.txt')
-rw-r--r--tests/manual/lance/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/tests/manual/lance/CMakeLists.txt b/tests/manual/lance/CMakeLists.txt
index 3b932c3629..41eb18b6c2 100644
--- a/tests/manual/lance/CMakeLists.txt
+++ b/tests/manual/lance/CMakeLists.txt
@@ -1,4 +1,5 @@
-# Generated from lance.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## lance Binary:
@@ -10,10 +11,12 @@ qt_internal_add_manual_test(lance
interactivewidget.cpp interactivewidget.h
main.cpp
widgets.h
+ NO_PCH_SOURCES
+ interactivewidget.cpp # undef QT_NO_FOREACH
INCLUDE_DIRECTORIES
.
../../baseline/shared
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
@@ -74,14 +77,10 @@ qt_internal_add_resource(lance "images"
${images_resource_files}
)
-
-#### Keys ignored in scope 1:.:.:lance.pro:<TRUE>:
-# TEMPLATE = "app"
-
## Scopes:
#####################################################################
qt_internal_extend_target(lance CONDITION TARGET Qt::OpenGL
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::OpenGL
)