summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/floattexture/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/floattexture/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/floattexture/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/manual/rhi/floattexture/CMakeLists.txt b/tests/manual/rhi/floattexture/CMakeLists.txt
new file mode 100644
index 0000000000..b87ddabab8
--- /dev/null
+++ b/tests/manual/rhi/floattexture/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from floattexture.pro.
+
+#####################################################################
+## floattexture Binary:
+#####################################################################
+
+add_qt_manual_test(floattexture
+ GUI
+ SOURCES
+ floattexture.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+# Resources:
+set_source_files_properties("../shared/OpenfootageNET_fieldairport-512.hdr"
+ PROPERTIES QT_RESOURCE_ALIAS "OpenfootageNET_fieldairport-512.hdr"
+)
+set_source_files_properties("../shared/texture.frag.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "texture.frag.qsb"
+)
+set_source_files_properties("../shared/texture.vert.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "texture.vert.qsb"
+)
+set(floattexture_resource_files
+ "../shared/OpenfootageNET_fieldairport-512.hdr"
+ "../shared/texture.frag.qsb"
+ "../shared/texture.vert.qsb"
+)
+
+add_qt_resource(floattexture "floattexture"
+ PREFIX
+ "/"
+ FILES
+ ${floattexture_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:floattexture.pro:<TRUE>:
+# TEMPLATE = "app"