summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/hellominimalcrossgfxtriangle/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/hellominimalcrossgfxtriangle/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/hellominimalcrossgfxtriangle/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/manual/rhi/hellominimalcrossgfxtriangle/CMakeLists.txt b/tests/manual/rhi/hellominimalcrossgfxtriangle/CMakeLists.txt
new file mode 100644
index 0000000000..8b9d3389f8
--- /dev/null
+++ b/tests/manual/rhi/hellominimalcrossgfxtriangle/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from hellominimalcrossgfxtriangle.pro.
+
+#####################################################################
+## hellominimalcrossgfxtriangle Binary:
+#####################################################################
+
+add_qt_manual_test(hellominimalcrossgfxtriangle
+ SOURCES
+ hellowindow.cpp hellowindow.h
+ main.cpp
+ window.cpp window.h
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)
+
+# Resources:
+set_source_files_properties("../shared/color.frag.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "color.frag.qsb"
+)
+set_source_files_properties("../shared/color.vert.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "color.vert.qsb"
+)
+set(hellominimalcrossgfxtriangle_resource_files
+ "../shared/color.frag.qsb"
+ "../shared/color.vert.qsb"
+)
+
+add_qt_resource(hellominimalcrossgfxtriangle "hellominimalcrossgfxtriangle"
+ PREFIX
+ "/"
+ FILES
+ ${hellominimalcrossgfxtriangle_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:hellominimalcrossgfxtriangle.pro:<TRUE>:
+# TEMPLATE = "app"