summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/offscreen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/offscreen/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/offscreen/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/manual/rhi/offscreen/CMakeLists.txt b/tests/manual/rhi/offscreen/CMakeLists.txt
new file mode 100644
index 0000000000..ceefc4c0d6
--- /dev/null
+++ b/tests/manual/rhi/offscreen/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from offscreen.pro.
+
+#####################################################################
+## offscreen Binary:
+#####################################################################
+
+add_qt_manual_test(offscreen
+ SOURCES
+ offscreen.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+# Resources:
+set_source_files_properties("../shared/color.frag.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "color.frag.qsb"
+)
+set_source_files_properties("../shared/color.vert.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "color.vert.qsb"
+)
+set(offscreen_resource_files
+ "../shared/color.frag.qsb"
+ "../shared/color.vert.qsb"
+)
+
+add_qt_resource(offscreen "offscreen"
+ PREFIX
+ "/"
+ FILES
+ ${offscreen_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:offscreen.pro:<TRUE>:
+# TEMPLATE = "app"