summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/polygonmode/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/polygonmode/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/polygonmode/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/manual/rhi/polygonmode/CMakeLists.txt b/tests/manual/rhi/polygonmode/CMakeLists.txt
new file mode 100644
index 0000000000..ded4ca8d43
--- /dev/null
+++ b/tests/manual/rhi/polygonmode/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(polygonmode
+ GUI
+ SOURCES
+ polygonmode.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::GuiPrivate
+)
+
+set(polygonmode_resource_files
+ "test.vert.qsb"
+ "test.frag.qsb"
+)
+
+qt_internal_add_resource(polygonmode "polygonmode"
+ PREFIX
+ "/"
+ FILES
+ ${polygonmode_resource_files}
+)