summaryrefslogtreecommitdiffstats
path: root/tests/manual/rhi/texuploads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/rhi/texuploads/CMakeLists.txt')
-rw-r--r--tests/manual/rhi/texuploads/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/tests/manual/rhi/texuploads/CMakeLists.txt b/tests/manual/rhi/texuploads/CMakeLists.txt
new file mode 100644
index 0000000000..c2efd3a1ea
--- /dev/null
+++ b/tests/manual/rhi/texuploads/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from texuploads.pro.
+
+#####################################################################
+## texuploads Binary:
+#####################################################################
+
+add_qt_manual_test(texuploads
+ GUI
+ SOURCES
+ texuploads.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+)
+
+# Resources:
+set_source_files_properties("../shared/qt256.png"
+ PROPERTIES QT_RESOURCE_ALIAS "qt256.png"
+)
+set_source_files_properties("../shared/texture.frag.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "texture.frag.qsb"
+)
+set_source_files_properties("../shared/texture.vert.qsb"
+ PROPERTIES QT_RESOURCE_ALIAS "texture.vert.qsb"
+)
+set(texuploads_resource_files
+ "../shared/qt256.png"
+ "../shared/texture.frag.qsb"
+ "../shared/texture.vert.qsb"
+)
+
+add_qt_resource(texuploads "texuploads"
+ PREFIX
+ "/"
+ FILES
+ ${texuploads_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:texuploads.pro:<TRUE>:
+# TEMPLATE = "app"