summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/clipboard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/wasm/clipboard/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/clipboard/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/tests/manual/wasm/clipboard/CMakeLists.txt b/tests/manual/wasm/clipboard/CMakeLists.txt
new file mode 100644
index 0000000000..40fb8ca308
--- /dev/null
+++ b/tests/manual/wasm/clipboard/CMakeLists.txt
@@ -0,0 +1,40 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## clipboard Binary:
+#####################################################################
+
+qt_internal_add_manual_test(clipboard
+ GUI
+ SOURCES
+ main.cpp
+ mainwindow.cpp mainwindow.h mainwindow.ui
+ NO_PCH_SOURCES
+ main.cpp # undef QT_NO_FOREACH
+ LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+ ENABLE_AUTOGEN_TOOLS
+ uic
+)
+# Resources:
+set(data_resource_files
+ "data/qticon64.png"
+)
+
+qt_internal_add_resource(clipboard "data"
+ PREFIX
+ "/"
+ FILES
+ ${data_resource_files}
+)
+
+## Scopes:
+#####################################################################
+
+qt_internal_extend_target(clipboard CONDITION (QT_MAJOR_VERSION GREATER 4)
+ LIBRARIES
+ Qt::Widgets
+)