summaryrefslogtreecommitdiffstats
path: root/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt')
-rw-r--r--tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt b/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
new file mode 100644
index 0000000000..fe7cfb9030
--- /dev/null
+++ b/tests/manual/wasm/eventloop/asyncify_exec/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_manual_test(asyncify_exec
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Core
+)
+
+# Enable asyncify for this test. Also enable optimizations in order to reduce the binary size.
+target_link_options(asyncify_exec PUBLIC -sASYNCIFY -Os)