summaryrefslogtreecommitdiffstats
path: root/tests/auto/tools/qdbusxml2cpp/qdbusxml2cpp.pro
Commit message (Collapse)AuthorAgeFilesLines
* remove unnecessary references to $$QMAKE_CFLAGS_DBUSOswald Buddenhagen2016-10-041-1/+0
| | | | | | | | | | | it does not appear that the tests actually use these flags in any way; they don't include any (actual) d-bus headers and have no ifdefs. and the qdbus module already pulls in the flags via QMAKE_USE (in the case where they are defined at all, i.e., dbus-linked). Change-Id: Ie6bc6da7d1dd96da7b73f2d0fe45576936715874 Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
* Unify naming of LIBS/CFLAGS for 3rd party librariesLars Knoll2016-04-071-1/+1
| | | | | | | | Most libs use QMAKE_LIBS/CFLAGS, but some have other naming conventions. Unify them into using QMAKE_LIBS/CFLAGS. Change-Id: I39b188adc1f9a223a83b294c5315c3095a9c68de Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@theqtcompany.com>
* Remove QT_DISABLE_DEPRECATED_BEFORE=0 from tests not using deprecated API.Friedemann Kleint2015-09-011-1/+0
| | | | | Change-Id: I1955320e7639760b4383a53f37a506c8055933ef Reviewed-by: Liang Qi <liang.qi@theqtcompany.com>
* Set the Qt API level to compatibility mode in all tests.Thiago Macieira2012-08-011-0/+1
| | | | | | | | | | | Qt 5.0 beta requires changing the default to the 5.0 API, disabling the deprecated code. However, tests should test (and often do) the compatibility API too, so turn it back on. Task-number: QTBUG-25053 Change-Id: I8129c3ef3cb58541c95a32d083850d9e7f768927 Reviewed-by: Lars Knoll <lars.knoll@nokia.com> Reviewed-by: Olivier Goffart <ogoffart@woboq.com>
* Add unit testing for the qdbusxml2cpp toolThiago Macieira2012-04-211-0/+5
I have not added tests for warnings or other failure to input. This tests only proper output for the moment. Change-Id: Ie01fd2a78adfa57c27bf288a08cd44ae82f51241 Reviewed-by: Jason McDonald <jason.mcdonald@nokia.com>