summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 15:56:30 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-09-22 18:45:06 +0000
commite942e61b39b2988129ade944179a0c2c1bcdd6f0 (patch)
treebb4818ca37bbc558602d4ca3f1f17ed897cd7369
parentacfbd7006ec50190d70a9f393241d4b64caffa8f (diff)
CMake: Bump almost all cmake_minimum_required calls to 3.166.2
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Task-number: QTBUG-95018 Change-Id: I7c37c68825529e0c64600beee6607ee91d3a54dd Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Kai Koehne <kai.koehne@qt.io> (cherry picked from commit 9cd344ca47e0eb4986891a76e1fb7bf01d77e70c) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--CMakeLists.txt2
-rw-r--r--examples/charts/selectedbar/CMakeLists.txt2
-rw-r--r--tests/auto/cmake/CMakeLists.txt2
3 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b824480a..7d1235e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qtcharts.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtCharts
diff --git a/examples/charts/selectedbar/CMakeLists.txt b/examples/charts/selectedbar/CMakeLists.txt
index 55542a42..a293d64b 100644
--- a/examples/charts/selectedbar/CMakeLists.txt
+++ b/examples/charts/selectedbar/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from selectedbar.pro.
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(selectedbar LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 7f772845..6c8b1122 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -1,5 +1,5 @@
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 3.16)
project(qmake_cmake_files)