summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-02-04 18:36:18 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-02-05 04:02:06 +0000
commit0d1fb19fddfa3e7884eafd0e0aecbd50a87f1acb (patch)
tree57a4b75ec519be470e580cdfbc05373e88b3fa41 /examples/CMakeLists.txt
parentb1cdbca24b7f8441e0d859a81e3723cd4a92e3ba (diff)
Switch examples to build as isolated sub-builds part 2
qt_examples_build_begin needs the EXTERNAL_BUILD flag to know that it's safe to build examples as ExternalProjects. It still won't do it in CI until we enable building examples as ExternalProjects for prefix builds. This is preparation for that. Task-number: QTBUG-90820 Change-Id: I3b68481ed3fafed0e279a69ba040fa4a325861af Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> (cherry picked from commit 61ef8d2f00bc9c10b54ea583f8f5e5fcaf9458f3) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 7613c97b..4eb2527b 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from examples.pro.
-qt_examples_build_begin()
+qt_examples_build_begin(EXTERNAL_BUILD)
add_subdirectory(charts)