summaryrefslogtreecommitdiffstats
path: root/examples/charts/horizontalstackedbarchart/CMakeLists.txt
diff options
context:
space:
mode:
authorMiikka Heikkinen <miikka.heikkinen@qt.io>2023-05-19 13:58:19 +0300
committerMiikka Heikkinen <miikka.heikkinen@qt.io>2023-06-13 14:23:13 +0300
commitcf7c6bd4900e333b45964740f0a199b9d8709a3d (patch)
treefb3e56fc1d7e9f7becad52857d282f437630a6b7 /examples/charts/horizontalstackedbarchart/CMakeLists.txt
parent143a6627b30954ae05c49bd59dd5f91427651a97 (diff)
Revamp examples
Separate gallery example was created for widget and qml examples and most example code was moved under those two gallery examples. Examples left outside galleries for various reasons: - audio: Requires multimedia, which is an optional addon - openglseries: Requires OpenGL backend - qmloscilloscope: Complicated hybrid C++/QML example - qmlweather: Uses optional command line parameter - zoomlinechart: Uses gestures, which require grabbing main window Cleaned up the code of the remaining examples to same standard as galleries. Examples documentation will be updated in a separate commit. Task-number: QTBUG-94181 Task-number: QTBUG-111053 Task-number: QTBUG-113655 Change-Id: I6a98a4386364fcb2530e2667aea95760e6ff2983 Reviewed-by: Mahmoud Badri <mahmoud.badri@qt.io> (cherry picked from commit 8f4629814f3df83e9ea85aebefb0e0c9929be476) Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/charts/horizontalstackedbarchart/CMakeLists.txt')
-rw-r--r--examples/charts/horizontalstackedbarchart/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/examples/charts/horizontalstackedbarchart/CMakeLists.txt b/examples/charts/horizontalstackedbarchart/CMakeLists.txt
deleted file mode 100644
index 0b51114e..00000000
--- a/examples/charts/horizontalstackedbarchart/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(horizontalstackedbarchart LANGUAGES CXX)
-
-set(CMAKE_AUTOMOC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/charts/horizontalstackedbarchart")
-
-find_package(Qt6 REQUIRED COMPONENTS Charts Core Gui)
-
-qt_add_executable(horizontalstackedbarchart
- main.cpp
-)
-
-set_target_properties(horizontalstackedbarchart PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(horizontalstackedbarchart PUBLIC
- Qt::Charts
- Qt::Core
- Qt::Gui
-)
-
-install(TARGETS horizontalstackedbarchart
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)