summaryrefslogtreecommitdiffstats
path: root/examples/charts/qmlweather/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2020-07-29 08:43:00 +0200
committerMichal Klocek <michal.klocek@qt.io>2021-01-06 14:30:18 +0100
commit7cec30a15f4712e782bb1011d2b93e6bf77cce6b (patch)
tree256ab9e7468aa1318f1fa7d26387693cd850349a /examples/charts/qmlweather/CMakeLists.txt
parent3ef94e711f35b17efdb2a3638a60a67021a44190 (diff)
Add cmake build
Task-number: QTBUG-89091 Change-Id: Ie511e6bc262f197b2c21e52ec7696a0d50e06d18 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/charts/qmlweather/CMakeLists.txt')
-rw-r--r--examples/charts/qmlweather/CMakeLists.txt56
1 files changed, 56 insertions, 0 deletions
diff --git a/examples/charts/qmlweather/CMakeLists.txt b/examples/charts/qmlweather/CMakeLists.txt
new file mode 100644
index 00000000..314ece1b
--- /dev/null
+++ b/examples/charts/qmlweather/CMakeLists.txt
@@ -0,0 +1,56 @@
+# Generated from qmlweather.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(qmlweather LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/charts/qmlweather")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Charts)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+qt_add_executable(qmlweather
+ main.cpp
+)
+set_target_properties(qmlweather PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(qmlweather PUBLIC
+ Qt::Charts
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(resources_resource_files
+ "qml/qmlweather/main.qml"
+)
+
+qt6_add_resources(qmlweather "resources"
+ PREFIX
+ "/"
+ FILES
+ ${resources_resource_files}
+)
+
+install(TARGETS qmlweather
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)