summaryrefslogtreecommitdiffstats
path: root/examples/charts/piechartcustomization/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/charts/piechartcustomization/CMakeLists.txt')
-rw-r--r--examples/charts/piechartcustomization/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/examples/charts/piechartcustomization/CMakeLists.txt b/examples/charts/piechartcustomization/CMakeLists.txt
new file mode 100644
index 00000000..3bf78144
--- /dev/null
+++ b/examples/charts/piechartcustomization/CMakeLists.txt
@@ -0,0 +1,43 @@
+# Generated from piechartcustomization.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(piechartcustomization LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/charts/piechartcustomization")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Charts)
+
+qt_add_executable(piechartcustomization
+ brushtool.cpp brushtool.h
+ customslice.cpp customslice.h
+ main.cpp
+ mainwidget.cpp mainwidget.h
+ pentool.cpp pentool.h
+)
+set_target_properties(piechartcustomization PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(piechartcustomization PUBLIC
+ Qt::Charts
+ Qt::Core
+ Qt::Gui
+)
+
+install(TARGETS piechartcustomization
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)