summaryrefslogtreecommitdiffstats
path: root/examples/charts/qmlf1legends/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/charts/qmlf1legends/CMakeLists.txt')
-rw-r--r--examples/charts/qmlf1legends/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/examples/charts/qmlf1legends/CMakeLists.txt b/examples/charts/qmlf1legends/CMakeLists.txt
new file mode 100644
index 00000000..354a11b5
--- /dev/null
+++ b/examples/charts/qmlf1legends/CMakeLists.txt
@@ -0,0 +1,57 @@
+# Generated from qmlf1legends.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(qmlf1legends LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/charts/qmlf1legends")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Charts)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+qt_add_executable(qmlf1legends
+ main.cpp
+)
+set_target_properties(qmlf1legends PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(qmlf1legends PUBLIC
+ Qt::Charts
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(resources_resource_files
+ "qml/qmlf1legends/SpeedsXml.qml"
+ "qml/qmlf1legends/main.qml"
+)
+
+qt6_add_resources(qmlf1legends "resources"
+ PREFIX
+ "/"
+ FILES
+ ${resources_resource_files}
+)
+
+install(TARGETS qmlf1legends
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)