summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVille Voutilainen <ville.voutilainen@qt.io>2021-05-17 17:11:23 +0300
committerVille Voutilainen <ville.voutilainen@qt.io>2021-06-04 15:08:23 +0300
commit7d2c6ae66fd61be56b35ae0c59354b695a02d6c7 (patch)
tree5858ea994587fb7955a05674bc22efbdb0f0f3b4 /CMakeLists.txt
parent09c8d5df77f3a5bffdf698d62ca0cf6179182060 (diff)
Remove AndroidExtras dependencies and port to new Qt 6 Android APIs
Task-number: QTBUG-93811 Change-Id: Ia3eb9ad90f27614db5997e1f41f13e050f5f4ab7 Reviewed-by: Ivan Solovev <ivan.solovev@qt.io> Reviewed-by: Rami Potinkara <rami.potinkara@qt.io> Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io> Reviewed-by: Andreas Buhr <andreas.buhr@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06a142e2..f4ebbd2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,16 +14,10 @@ set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets Quick)
-if(ANDROID)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)
-endif()
if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
return()
endif()
-if(ANDROID AND NOT TARGET Qt::AndroidExtras)
- message(NOTICE "Skipping the build as the condition \"TARGET Qt::AndroidExtras OR NOT ANDROID\" is not met.")
- return()
-endif()
+
qt_build_repo()