summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIevgenii Meshcheriakov <ievgenii.meshcheriakov@qt.io>2022-11-09 15:56:22 +0100
committerIevgenii Meshcheriakov <ievgenii.meshcheriakov@qt.io>2023-02-08 15:14:00 +0100
commit115b4d947adf90a706f76de831f34960e3c62a9c (patch)
treec714ea5eb83021831baa8a0678a1a1d0dbb87eed /CMakeLists.txt
parent849ba86ba9a073a266219b6a39786e20f4f3ed7b (diff)
QtNfc: Rewrite NDEF Editor example using Qt Quick Components
This makes the example look more native on mobile platforms. Leave only the functionality related to reading and writing of text and URI NDEF records to simplify the code. Removed functionality includes saving/reading messages to files, and support for image NDEF records. Pick-to: 6.5 Fixes: QTBUG-103949 Change-Id: Ie14e3009e2d0238b266eb9690795ca6b56c0010c Reviewed-by: Mitch Curtis <mitch.curtis@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cba619fb..f5db4b62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,8 @@ project(QtConnectivity
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets Quick)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
+ DBus Gui Widgets Quick QuickControls2)
if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")