summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-19 15:33:47 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-21 20:24:36 +0200
commit36f103904dc015a0f3f99db5b811f2e9fa12f850 (patch)
tree240e973b2385f67c5e8e32d0ec423c0597dfa7e9 /CMakeLists.txt
parentf1df1c78c86332e76c1c66db4a63cc4505c8c433 (diff)
Use fixed qt_add_resource BASE argument
Task-number: QTBUG-86726 Change-Id: I8372086c40043a6bd1d306b6bfb711e96ddc7cb7 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f32f3e8..06a142e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,9 @@ project(QtConnectivity
LANGUAGES CXX C
)
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
+
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets Quick)