summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Buhr <andreas@andreasbuhr.de>2021-03-02 16:37:16 +0100
committerAndreas Buhr <andreas@andreasbuhr.de>2021-03-04 10:59:10 +0100
commit65ae6075c1acf0f720a0e4ab0080e828db5db36b (patch)
treee8197e4e65ade6353da4a833694a65f01a358e42 /CMakeLists.txt
parent968dd1468f1befcf286e4bdc8f0617dc390b15d2 (diff)
remove QtConcurrent dependency
QtBluetooth used QtConcurrent internally in the past. This is no longer the case. The dependency can be removed. Fixes: QTBUG-89494 Change-Id: I7e0657f79bc02ec794311d25d245a7ae5cef02e7 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1414cd05..98332e5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,7 @@ project(QtConnectivity
)
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network
- Concurrent)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets Quick)
if(ANDROID)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)