summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Buhr <andreas@andreasbuhr.de>2020-12-17 19:19:18 +0100
committerAndreas Buhr <andreas@andreasbuhr.de>2020-12-21 14:26:23 +0100
commit7059487ccba77d6d05bc985d5cd9b49c90d8042c (patch)
treebfc957a2447ca71aa213da5bf10e887b64a0b536 /CMakeLists.txt
parent5f84f4e90d45061200873a768fee81eb8e475f98 (diff)
Update CMake scripts in QtConnectivity
Recreated all CMake files in QtConnectivity using run_pro2cmake.py . --only-existing -- --api-version 3 Furthermore, port bttestui to CMake. Change-Id: Idb55f1b4c1cff30d7824a42e3ee6923c39e698df Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26909b2d..790065c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,9 +12,9 @@ project(QtConnectivity # special case
# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network
- Concurrent Widgets)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network
+ Concurrent)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets Quick)
if(ANDROID)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)
endif()