summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 17:23:57 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-12 16:45:53 +0000
commit782cbca1dcceef80a64dd1310ea854824c54665d (patch)
tree39dfa6ca8993da58bb75142f6fcb68f8021cafba /CMakeLists.txt
parentb50a574c8e2bf77c17fea3bfd490deb9b5fccace (diff)
Mark qtconnectivity as not being warnings clean
So that compilation doesn't fail when the WARNINGS_ARE_ERRORS option is enabled. This mimics what .qmake.conf warning_clean does. Change-Id: I05b04a35587aa254c758fb9256459817ae9dd832 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6016c51e..7ebed1e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ project(QtConnectivity # special case
)
# special case begin
+set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network
Concurrent Widgets)
# special case end