summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Buhr <andreas@andreasbuhr.de>2021-01-14 15:48:02 +0100
committerAndreas Buhr <andreas@andreasbuhr.de>2021-01-15 13:57:26 +0100
commit91c926e753b2cc3be65a42c877285d1bc6fedf11 (patch)
tree60a6bc0231f8212d3ba3d63032734340b81f2a6d /CMakeLists.txt
parent520e7870c70c6f55f1021ab219b9f5ed751a9ca2 (diff)
Remove all *.pro files and all "special case" markers in CMakeLists.txt
To use CMake only in the future to build QtConnectivity, all the traces from the qmake->CMake conversion can now be removed. This patch deletes all ".prev_CMakeLists.txt" files, in deletes all "*.pro" files and it removes all "special case" markers in CMakeLists.txt files. "special case" in "*.cmake" files are kept. Change-Id: Ia0f5d4de5d77b9f2e5cc8d97fc8f04077e042a6f Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 790065c3..1414cd05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,16 +1,13 @@
-# Generated from qtconnectivity.pro.
-
cmake_minimum_required(VERSION 3.15.0)
include(.cmake.conf)
-project(QtConnectivity # special case
+project(QtConnectivity
VERSION 6.0.0
- DESCRIPTION "Qt Connectivity Libraries" # special case
+ DESCRIPTION "Qt Connectivity Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network
Concurrent)
@@ -18,7 +15,6 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets
if(ANDROID)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)
endif()
-# special case end
if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")