summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Wolff <oliver.wolff@qt.io>2020-06-30 10:58:19 +0200
committerOliver Wolff <oliver.wolff@qt.io>2020-07-03 08:05:49 +0200
commitb23aa2b02920084a4f939283c0a41049c4d7aaf4 (patch)
tree73734e035b0d85d55eb074c90e6ba14e93b685fe /CMakeLists.txt
parent8e4c88f7761a4ce83836ec192ab31182d03b226b (diff)
Update CMakeLists.txt files
Result of reruns of pro2cmake, some manual fixes after the merge and one addition of the missing AndroidExtras dependency for Android. Change-Id: I5a124c51d0cb9be5767ee7185744aa0694cc2c7b Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ebed1e6..34451f02 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,9 @@ project(QtConnectivity # special case
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network
Concurrent Widgets)
+if(ANDROID)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)
+endif()
# special case end
if(NOT TARGET Qt::Network)