summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Wolff <oliver.wolff@qt.io>2019-09-23 12:16:44 +0200
committerOliver Wolff <oliver.wolff@qt.io>2019-10-24 11:22:55 +0000
commitb50a574c8e2bf77c17fea3bfd490deb9b5fccace (patch)
treeb5ab86ed19046ff084aa9c623fb093819fffbbc7 /CMakeLists.txt
parentdc34b1feabeb860f6ff6f59a430d730cbacd1948 (diff)
Port qtconnectivity to cmake
Also removed dependencies.yaml at the same time, as the new dependency tracking is not used in wip/cmake at the moment. Task-number: QTBUG-78181 Change-Id: I39c23da8daeedd86b7720d66d48ab0af3762083c Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..6016c51e
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from qtconnectivity.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+project(QtConnectivity # special case
+ VERSION 6.0.0
+ DESCRIPTION "Qt Connectivity Libraries" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+# special case begin
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network
+ Concurrent Widgets)
+# special case end
+
+if(NOT TARGET Qt::Network)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")
+ return()
+endif()
+if(ANDROID AND NOT TARGET Qt::AndroidExtras)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::AndroidExtras OR NOT ANDROID\" is not met.")
+ return()
+endif()
+qt_build_repo()