summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-06-05 15:40:28 +0200
committerFabian Kosmale <fabian.kosmale@qt.io>2021-06-05 15:50:59 +0200
commitd1dcdeef564005001be7d98ec781b717b281b071 (patch)
tree1bc15a319479514d467763efd1ffd4e7d6fa5ec9 /CMakeLists.txt
parent7d2c6ae66fd61be56b35ae0c59354b695a02d6c7 (diff)
CMake: Don't use internal compatibility API
Change-Id: Ia55eab18aae5c0f2f42f317e545668db87ba84aa Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4ebbd2a..d92e7b6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,9 @@ project(QtConnectivity
LANGUAGES CXX C
)
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
# Make sure we use the fixed BASE argument of qt_add_resource.
set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)