summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-08-14 12:45:21 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2020-08-14 13:15:37 +0300
commitd9956f03dfc5768a4810a743f92d0a59ef4f3403 (patch)
tree737f85625e25b51705f643a6287071b419c21cfc /CMakeLists.txt
parentaf86e275f71633b07ece5c13a1b9c789800ff68b (diff)
CMake: fix build with bluez
Use correct condition variable and make sure dbus can be used. Change-Id: Ie2c139e48c5ffa76c98ca60b3315db1de55cf711 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ef41583..26909b2d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ project(QtConnectivity # special case
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Network
Concurrent Widgets)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus)
if(ANDROID)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)
endif()