summaryrefslogtreecommitdiffstats
path: root/examples/bluetooth/btchat/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Wolff <oliver.wolff@qt.io>2019-09-23 12:16:44 +0200
committerOliver Wolff <oliver.wolff@qt.io>2019-10-24 11:22:55 +0000
commitb50a574c8e2bf77c17fea3bfd490deb9b5fccace (patch)
treeb5ab86ed19046ff084aa9c623fb093819fffbbc7 /examples/bluetooth/btchat/CMakeLists.txt
parentdc34b1feabeb860f6ff6f59a430d730cbacd1948 (diff)
Port qtconnectivity to cmake
Also removed dependencies.yaml at the same time, as the new dependency tracking is not used in wip/cmake at the moment. Task-number: QTBUG-78181 Change-Id: I39c23da8daeedd86b7720d66d48ab0af3762083c Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/bluetooth/btchat/CMakeLists.txt')
-rw-r--r--examples/bluetooth/btchat/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/examples/bluetooth/btchat/CMakeLists.txt b/examples/bluetooth/btchat/CMakeLists.txt
new file mode 100644
index 00000000..554920fd
--- /dev/null
+++ b/examples/bluetooth/btchat/CMakeLists.txt
@@ -0,0 +1,41 @@
+# Generated from btchat.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(btchat LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/bluetooth/btchat")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Bluetooth)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(btchat
+ chat.cpp chat.h chat.ui
+ chatclient.cpp chatclient.h
+ chatserver.cpp chatserver.h
+ main.cpp
+ remoteselector.cpp remoteselector.h remoteselector.ui
+)
+target_link_libraries(btchat PUBLIC
+ Qt::Bluetooth
+ Qt::Core
+ Qt::Widgets
+)
+
+if(ANDROID)
+ target_link_libraries(btchat PUBLIC
+ Qt::AndroidExtras
+ )
+endif()
+
+install(TARGETS btchat
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)