summaryrefslogtreecommitdiffstats
path: root/examples/bluetooth/pingpong/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Buhr <andreas@andreasbuhr.de>2021-02-12 18:31:31 +0100
committerAndreas Buhr <andreas@andreasbuhr.de>2021-02-15 13:07:36 +0100
commit4c0c80f60b2853ec073bb20883ce11da64a074b0 (patch)
tree3abf46f0ef6f6e8e1f14a1cd435224e0e009ae4b /examples/bluetooth/pingpong/CMakeLists.txt
parent764c1d056f95091f0e0207ad94aff99e363106fb (diff)
Fix btchat standalone build: find AndroidExtras before linking it
The btchat standalone build fails because AndroidExtras is linked which is unknown to CMake at that point. This patch adds the required find_package call. Change-Id: I1c505606fa65825adc605a05a24700e3a7b3bcc5 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'examples/bluetooth/pingpong/CMakeLists.txt')
-rw-r--r--examples/bluetooth/pingpong/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/bluetooth/pingpong/CMakeLists.txt b/examples/bluetooth/pingpong/CMakeLists.txt
index c771d16d..a18b690f 100644
--- a/examples/bluetooth/pingpong/CMakeLists.txt
+++ b/examples/bluetooth/pingpong/CMakeLists.txt
@@ -50,6 +50,7 @@ qt6_add_resources(pingpong "resource"
)
if(ANDROID)
+ find_package(Qt6 COMPONENTS AndroidExtras)
target_link_libraries(pingpong PUBLIC
Qt::AndroidExtras
)