summaryrefslogtreecommitdiffstats
path: root/examples/bluetooth/pingpong/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Blasche <alexander.blasche@qt.io>2021-04-26 11:31:55 +0200
committerAlex Blasche <alexander.blasche@qt.io>2021-04-26 14:23:55 +0200
commitc1237aab7924aebb596d3fd4c8270bd0cc53f323 (patch)
tree6ad5a4369d68c0621033df107ebc2987904d7c8b /examples/bluetooth/pingpong/CMakeLists.txt
parent673f6588325430b61ff788c46dde008261fef45f (diff)
Fix binary name clash with qtscxml example
See qtscxml/examples/statemachine/statemachine/pingpong for reference Fixes: QTBUG-92985 Change-Id: I00c2cb39d0f72be0790e55ce31419c5883b34e32 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/bluetooth/pingpong/CMakeLists.txt')
-rw-r--r--examples/bluetooth/pingpong/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/examples/bluetooth/pingpong/CMakeLists.txt b/examples/bluetooth/pingpong/CMakeLists.txt
index a18b690f..6f267ebc 100644
--- a/examples/bluetooth/pingpong/CMakeLists.txt
+++ b/examples/bluetooth/pingpong/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.14)
-project(pingpong LANGUAGES CXX)
+project(btpingpong LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -18,15 +18,16 @@ find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Quick)
find_package(Qt6 COMPONENTS Bluetooth)
-qt_add_executable(pingpong
+qt_add_executable(btpingpong
main.cpp
pingpong.cpp pingpong.h
)
-set_target_properties(pingpong PROPERTIES
+set_target_properties(btpingpong PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
+ OUTPUT_NAME "pingpong"
)
-target_link_libraries(pingpong PUBLIC
+target_link_libraries(btpingpong PUBLIC
Qt::Bluetooth
Qt::Core
Qt::Gui
@@ -42,7 +43,7 @@ set(resource_resource_files
"assets/main.qml"
)
-qt6_add_resources(pingpong "resource"
+qt6_add_resources(btpingpong "resource"
PREFIX
"/"
FILES
@@ -51,12 +52,12 @@ qt6_add_resources(pingpong "resource"
if(ANDROID)
find_package(Qt6 COMPONENTS AndroidExtras)
- target_link_libraries(pingpong PUBLIC
+ target_link_libraries(btpingpong PUBLIC
Qt::AndroidExtras
)
endif()
-install(TARGETS pingpong
+install(TARGETS btpingpong
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"