summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 790065c3..1414cd05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,16 +1,13 @@
-# Generated from qtconnectivity.pro.
-
cmake_minimum_required(VERSION 3.15.0)
include(.cmake.conf)
-project(QtConnectivity # special case
+project(QtConnectivity
VERSION 6.0.0
- DESCRIPTION "Qt Connectivity Libraries" # special case
+ DESCRIPTION "Qt Connectivity Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-# special case begin
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Network
Concurrent)
@@ -18,7 +15,6 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS DBus Gui Widgets
if(ANDROID)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS AndroidExtras)
endif()
-# special case end
if(NOT TARGET Qt::Network)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Network\" is not met.")