summaryrefslogtreecommitdiffstats
path: root/tests/manual/qlowenergycontroller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qlowenergycontroller/CMakeLists.txt')
-rw-r--r--tests/manual/qlowenergycontroller/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/manual/qlowenergycontroller/CMakeLists.txt b/tests/manual/qlowenergycontroller/CMakeLists.txt
index 6573c19c..022433ee 100644
--- a/tests/manual/qlowenergycontroller/CMakeLists.txt
+++ b/tests/manual/qlowenergycontroller/CMakeLists.txt
@@ -44,13 +44,15 @@ set_target_properties(tst_qlowenergycontroller_device PROPERTIES
)
if(APPLE)
+ # Ninja has trouble with relative paths, convert to absolute as a workaround
+ get_filename_component(SHARED_PLIST_DIR ${CMAKE_CURRENT_SOURCE_DIR}/../../shared ABSOLUTE)
if(IOS)
set_target_properties(tst_qlowenergycontroller_device PROPERTIES
- MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.ios.plist"
+ MACOSX_BUNDLE_INFO_PLIST "${SHARED_PLIST_DIR}/Info.ios.plist"
)
else()
set_target_properties(tst_qlowenergycontroller_device PROPERTIES
- MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.macos.plist"
+ MACOSX_BUNDLE_INFO_PLIST "${SHARED_PLIST_DIR}/Info.macos.plist"
)
endif()
endif()