summaryrefslogtreecommitdiffstats
path: root/tests/manual/qlowenergycontroller/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qlowenergycontroller/CMakeLists.txt')
-rw-r--r--tests/manual/qlowenergycontroller/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/manual/qlowenergycontroller/CMakeLists.txt b/tests/manual/qlowenergycontroller/CMakeLists.txt
index 0a2a89da..6573c19c 100644
--- a/tests/manual/qlowenergycontroller/CMakeLists.txt
+++ b/tests/manual/qlowenergycontroller/CMakeLists.txt
@@ -1,3 +1,28 @@
+cmake_minimum_required(VERSION 3.16...3.21)
+
+if(NOT TARGET Qt::Bluetooth)
+ # for standalone build (and the only way for iOS)
+ project(tst_qlowenergycontroller_device LANGUAGES CXX)
+
+ set(CMAKE_AUTOMOC ON)
+
+ find_package(Qt6 COMPONENTS Bluetooth Core Test Gui)
+
+ qt_add_executable(
+ tst_qlowenergycontroller_device
+ tst_qlowenergycontroller_device.cpp
+ )
+ target_link_libraries(
+ tst_qlowenergycontroller_device
+ PUBLIC
+ Qt::Core
+ Qt::Bluetooth
+ Qt::Test
+ Qt::Gui
+ )
+
+else()
+
qt_internal_add_test(tst_qlowenergycontroller_device
SOURCES
tst_qlowenergycontroller_device.cpp
@@ -11,6 +36,8 @@ qt_internal_extend_target(tst_qlowenergycontroller_device
QT_ANDROID_BLUETOOTH
)
+endif()
+
set_target_properties(tst_qlowenergycontroller_device PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE