summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-21 20:38:30 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-22 21:12:42 +0200
commit559213087ded2f68867a081d8f64d16bfac5e6fd (patch)
treea26a6c2a04dc793d535e5010e5f62dc1f022bb30 /CMakeLists.txt
parent054c07b2ac51d134edd6eef6f3897470978cd7e4 (diff)
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I657ce43f65def5a13ca14030215a8adc37690d20 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef65310a..9a274eab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,9 @@ project(QtDataVisualization
LANGUAGES CXX C
)
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
Core OpenGL Quick Qml Gui Widgets QuickTest Test)