summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomo Pelkonen <tuomo.pelkonen@gmail.com>2021-01-28 13:07:18 +0200
committerTomi Korpipaa <tomi.korpipaa@qt.io>2021-02-10 12:49:14 +0200
commitd2c6249bb9292deec97b5a026be5efdb7a83bba7 (patch)
tree79cb6a394efede2467476866e525ad349f3d74fd /CMakeLists.txt
parentdb093d4229cbfb8a27a345c7568ee0b56dec960b (diff)
Fix build for Qt 6.1
Task-number: QTBUG-89299 Task-number: QTBUG-90926 Pick-to: 6.1 Change-Id: I49822338f94e2bdcb0ae5b29d2211127e40d58f9 Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 458a9f9f..ef65310a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,9 @@ project(QtDataVisualization
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core OpenGL Quick Qml)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Widgets OpenGLWidgets QuickTest Test)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
+ Core OpenGL Quick Qml Gui Widgets QuickTest Test)
macro(assertTargets)
foreach(qtTarget IN ITEMS ${ARGN})