summaryrefslogtreecommitdiffstats
path: root/examples/datavisualization/qml3doscilloscope/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Korpipaa <tomi.korpipaa@qt.io>2021-03-26 09:36:15 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-03-26 09:06:42 +0000
commit1d067e8aa9bddd056447aefb5b626b3b0db5ab63 (patch)
tree3a3e0e66862e7e309ab281b14cbfe8752bfc756b /examples/datavisualization/qml3doscilloscope/CMakeLists.txt
parent5928a0529c3b25dd30ac5df16cb28bc33f1563c0 (diff)
Rename qmloscilloscope
There was a naming conflict with QtCharts qmloscilloscope example, so this is now renamed as qml3doscilloscope Fixes: QTBUG-92167 Change-Id: I657d9737c39b0680aabc6b7c00ebe04351643502 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jani Heikkinen <jani.heikkinen@qt.io> (cherry picked from commit 695276e2c4725d67960aa212043fe1b86c47fe95) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/datavisualization/qml3doscilloscope/CMakeLists.txt')
-rw-r--r--examples/datavisualization/qml3doscilloscope/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/examples/datavisualization/qml3doscilloscope/CMakeLists.txt b/examples/datavisualization/qml3doscilloscope/CMakeLists.txt
new file mode 100644
index 00000000..f37e9c5d
--- /dev/null
+++ b/examples/datavisualization/qml3doscilloscope/CMakeLists.txt
@@ -0,0 +1,52 @@
+cmake_minimum_required(VERSION 3.14)
+project(qml3doscilloscope LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+qt_add_executable(qml3doscilloscope
+ datasource.cpp datasource.h
+ main.cpp
+)
+set_target_properties(qml3doscilloscope PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(qml3doscilloscope PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::DataVisualization
+)
+
+set(qml3doscilloscope_resource_files
+ "qml/qml3doscilloscope/main.qml"
+)
+
+qt6_add_resources(qml3doscilloscope "qml3doscilloscope"
+ PREFIX
+ "/"
+ FILES
+ ${qml3doscilloscope_resource_files}
+)
+
+install(TARGETS qml3doscilloscope
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)