summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomo Pelkonen <tuomo.pelkonen@gmail.com>2021-01-20 15:18:03 +0200
committerTuomo Pelkonen <tuomo.pelkonen@gmail.com>2021-01-27 13:16:44 +0200
commite2e20c9f1180476193baa32cf7a50252f35f01f3 (patch)
tree54871adbc899181d149eed413570c79b13058074 /tests/auto/CMakeLists.txt
parentff193e33d80a08ca0c21fdbccc2d63e6b7400d88 (diff)
Add CMake build
Task-number: QTBUG-89299 Change-Id: I5becbf39605e566c3d32cb5e210d974df9de27da Reviewed-by: Miikka Heikkinen <miikka.heikkinen@qt.io> Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
new file mode 100644
index 00000000..ffa2e824
--- /dev/null
+++ b/tests/auto/CMakeLists.txt
@@ -0,0 +1,6 @@
+if(NOT ANDROID)
+ add_subdirectory(cpptest)
+endif()
+if(TARGET Qt::Quick AND NOT boot2qt)
+ add_subdirectory(qmltest)
+endif()