summaryrefslogtreecommitdiffstats
path: root/tests/auto/cpptest/CMakeLists.txt
diff options
context:
space:
mode:
authorSami Varanka <sami.varanka@qt.io>2021-08-04 16:30:40 +0300
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-08-11 10:36:21 +0000
commit5fd3b8302f43d414e1096a62118df17e22e160a5 (patch)
tree60ac6684baf76542f5752ba60e4d4796f68a9f5b /tests/auto/cpptest/CMakeLists.txt
parentdceb7c77250e1407e5bd393245bb8de6d358b216 (diff)
Fix: Nans at surfacedata row/column 0 render fail
If the first or last column or row of the data given to surfacedataproxy contains NaN values, the surfacedataproxy might fail to find the limit values for the axis. Changed limitValues function in surfacedataproxy so that if it doesn't find min/max values from the first/last column/row it continues from the next column/row. Added a test to verify that the limit values are found when first/last row contains NaN values. Change-Id: Ica3eebb1c6072656f59394814c3fa5e334f12c54 Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io> (cherry picked from commit a9ccf1c7a1ccc7499e9a0d6178e9555caa364901) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/auto/cpptest/CMakeLists.txt')
-rw-r--r--tests/auto/cpptest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/cpptest/CMakeLists.txt b/tests/auto/cpptest/CMakeLists.txt
index 7b6ef00b..bed23651 100644
--- a/tests/auto/cpptest/CMakeLists.txt
+++ b/tests/auto/cpptest/CMakeLists.txt
@@ -9,6 +9,7 @@ add_subdirectory(q3dscatter-series)
add_subdirectory(q3dsurface)
add_subdirectory(q3dsurface-proxy)
add_subdirectory(q3dsurface-modelproxy)
+add_subdirectory(q3dsurface-modelproxy-nan)
add_subdirectory(q3dsurface-heightproxy)
add_subdirectory(q3dsurface-series)
add_subdirectory(q3daxis-category)