summaryrefslogtreecommitdiffstats
path: root/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
diff options
context:
space:
mode:
authorTuomo Pelkonen <tuomo.pelkonen@gmail.com>2021-01-20 15:18:03 +0200
committerTuomo Pelkonen <tuomo.pelkonen@gmail.com>2021-01-27 13:16:44 +0200
commite2e20c9f1180476193baa32cf7a50252f35f01f3 (patch)
tree54871adbc899181d149eed413570c79b13058074 /tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
parentff193e33d80a08ca0c21fdbccc2d63e6b7400d88 (diff)
Add CMake build
Task-number: QTBUG-89299 Change-Id: I5becbf39605e566c3d32cb5e210d974df9de27da Reviewed-by: Miikka Heikkinen <miikka.heikkinen@qt.io> Reviewed-by: Tomi Korpipää <tomi.korpipaa@qt.io>
Diffstat (limited to 'tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt')
-rw-r--r--tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt b/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
new file mode 100644
index 00000000..8132c2a6
--- /dev/null
+++ b/tests/auto/cpptest/q3dsurface-heightproxy/CMakeLists.txt
@@ -0,0 +1,18 @@
+qt_add_test(q3dsurface-heightproxy
+ SOURCES
+ tst_proxy.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::DataVisualization
+)
+
+set(q3dsurface-heightproxy_resource_files
+ "customtexture.jpg"
+)
+
+qt_add_resource(q3dsurface-heightproxy "q3dsurface-heightproxy"
+ PREFIX
+ "/"
+ FILES
+ ${q3dsurface-heightproxy_resource_files}
+)